quiz installing problems

Discussion in 'General Scripting Language Discussion' started by mrselnombre, Mar 30, 2004.

  1. mrselnombre New Member

    i have just installed a quiz on my site. chmodded all the files correctly, but for some reason it isn't working

    http://www.totaltwaddle.co.uk/quiz/ what causes that error,
    i tried the help files that came with it but nothing.... and i am posting it here as it isn't a server/hosting issue?

    :cry:
  2. Jack HU Moderator

    :shifty:

    That's odd. Doesn't look like the server's restricting access from CHMOD, normally you'd get a 403 Forbidden page. I'm pretty sure despammed or burningsnowman will know the answer to this :)
  3. mrselnombre New Member

    i had a similar problem with an image program i uploaded, and changing the .htaccess sorted that... but there is no .htacess in that folder...

    i am completely flumoxed
  4. andy_capp New Member

    Ehh... /quiz/ You have banned from accessing this site. :wallbash: Firstime i've been on your site :confused:
  5. mrselnombre New Member

    i get that too and it's my site....
    mee thinks it's broken
  6. andy_capp New Member

    Where'd you get the quiz from?
  7. mrselnombre New Member

  8. andy_capp New Member

    There's no where in the code that i could see that refers to the string "You have banned from accessing this site"

    Have you set one of your error messages up as this?
  9. mrselnombre New Member

    no i haven't...

    told you i was flumoxed
  10. despammed Wireless bandwidth abuse!

    What's in the error log? Can you post it here with code tags?
  11. mrselnombre New Member

    here is what is in my error log minus i.p
    [Tue Mar 30 23:10:12 2004] [error] [client ********] Options ExecCGI is off in this directory: /home/mrselnom/public_html/quiz/index.cgi[/
  12. despammed Wireless bandwidth abuse!

    That's odd, On Titan I can run CGI anywhere... Try moving it to the cgi-bin folder, and then double check the permissions.
  13. mrselnombre New Member

    ok, i'll give it ago, but i checked the permission so they are exactly what the help files say they are...

    watch this space
  14. mrselnombre New Member

    nope same error....?

    actually i get this
    /cgi-bin/quiz You have banned from accessing this site.
  15. despammed Wireless bandwidth abuse!

    Try accessing the .cgi directly?
  16. mrselnombre New Member

    ok i tried this addy
    http://www.totaltwaddle.co.uk/cgi-bin/quiz/index.cgi

    and got this error

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@totaltwaddle.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
  17. despammed Wireless bandwidth abuse!

    Now look at the log...
  18. mrselnombre New Member

    ahh haaa right

    [Wed Mar 31 10:16:35 2004] [error] [client .......] Premature end of script headers: /home/mrselnom/public_html/cgi-bin/quiz/index.cgi
    [Wed Mar 31 10:00:25 2004] [error] [client .......] File does not exist: /home/mrselnom/public_html/500.shtml
    [Wed Mar 31 10:00:25 2004] [error] [client ........] Premature end of script headers: /home/mrselnom/public_html/cgi-bin/quiz/index.cgi
    [Wed Mar 31 09:47:22 2004] [error] [client ............] Premature end of script headers: /home/mrselnom/public_html/cgi-bin/quiz/index.cgi
    [Wed Mar 31 09:47:05 2004] [error] [client ..........] attempt to invoke directory as script: /home/mrselnom/public_html/cgi-bin/quiz
    [Wed Mar 31 09:42:19 2004] [error] [client ......] attempt to invoke directory as script: /home/mrselnom/public_html/cgi-bin/quiz
  19. despammed Wireless bandwidth abuse!

    Premature end of script headers - Upload the script in acsii mode rather than binary ?
  20. mrselnombre New Member

    i uploaded it acsii... should i try binary?

Share This Page